啟迪大眾分享網

通達信多個公式怎么一并導出,通達信軟件怎么導出公式

內容導航:
  • 通達信什么只能導出.tn6格式的公式
  • 通達信選股公式如何把兩個公式合成一個公式?并且符合兩種公式的任何一種都能選出出來
  • 通達信選股公式怎么合并 輸出不能超過一個 求老師幫忙
  • 通達信公式怎么合并
  • 通達信軟件的指標模板如何導出?
  • 通達信怎么保存公式
  • Q1:通達信什么只能導出.tn6格式的公式

    不同的軟件是不能直接導入的,這個要打開公式編輯器,點修改公式復制源碼再到通達信同樣打開公式編輯器新建公式,黏貼源碼,確定就成功了只能一個一個的用源碼新建公式 ,之后再從公式編輯器導出就是tni格式了.百度找的....

    Q2:通達信選股公式如何把兩個公式合成一個公式?并且符合兩種公式的任何一種都能選出出來

    MA1:=MA(CLOSE,4);
    MA2:=MA(CLOSE,13);
    MA3:=MA(CLOSE,165);
    A1:=OPEN<MA1 OR OPEN<MA2 OR OPEN<MA3;
    A2:=C>MAX(MA1,MAX(MA2,MA3));
    A3:=V/MA(V,30)>1.2;
    A4:=C/REF(C,1)>1.049;
    MA11:=MA(CLOSE,13);
    MA12:=MA(CLOSE,26);
    MA13:=MA(CLOSE,165);
    A11:=OPEN<MA11 OR OPEN<MA12 OR OPEN<MA13;
    A12:=C>MAX(MA11,MAX(MA12,MA13));
    A13:=V/MA(V,30)>1.2;
    A14:=C/REF(C,1)>1.049;
    出水芙蓉:A1 && A2 && A3 && A4 && A11&& A12;

    Q3:通達信選股公式怎么合并 輸出不能超過一個 求老師幫忙

    {信號同時滿足}
    {公式一 }
    DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
    DEA:=EMA(DIFF,5);
    A1:=DIFF>DEA;
    RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
    K:=SMA(RSV1,3,1);
    D:=SMA(K,3,1);
    A2:=K>D;
    LC:=REF(CLOSE,1);
    RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
    RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
    A3:=RSI1>RSI2;
    RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
    LWR1:=SMA(RSV,3,1);
    LWR2:=SMA(LWR1,3,1);
    A4:=LWR1>LWR2;
    BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
    A5:=CLOSE>BBI;
    MTM:=CLOSE-REF(CLOSE,1);
    MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
    MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
    A6:=MMS>MMM;
    漲買入:=IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0);
    {公式二}
    丁丁1:=EMA(C,3);
    丁丁2:=EMA(C,5);
    丁丁3:=EMA(C,7);
    丁丁4:=EMA(C,12);
    丁丁5:=EMA(C,20);
    SS:=CROSS(丁丁1,丁丁2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁1,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁2,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁1,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁1,丁丁4);
    DD:=CROSS(丁丁2,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁2,丁丁5) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁3,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁2,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁1,丁丁5);
    XG:漲買入 AND SS AND DD;
    =======================
    {滿足其中一個信號}
    {公式一 }
    DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
    DEA:=EMA(DIFF,5);
    A1:=DIFF>DEA;
    RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
    K:=SMA(RSV1,3,1);
    D:=SMA(K,3,1);
    A2:=K>D;
    LC:=REF(CLOSE,1);
    RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
    RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
    A3:=RSI1>RSI2;
    RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
    LWR1:=SMA(RSV,3,1);
    LWR2:=SMA(LWR1,3,1);
    A4:=LWR1>LWR2;
    BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
    A5:=CLOSE>BBI;
    MTM:=CLOSE-REF(CLOSE,1);
    MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
    MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
    A6:=MMS>MMM;
    漲買入:=IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0);
    {公式二}
    丁丁1:=EMA(C,3);
    丁丁2:=EMA(C,5);
    丁丁3:=EMA(C,7);
    丁丁4:=EMA(C,12);
    丁丁5:=EMA(C,20);
    SS:=CROSS(丁丁1,丁丁2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁1,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁2,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁1,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁1,丁丁4);
    DD:=CROSS(丁丁2,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁2,丁丁5) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁3,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁2,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁1,丁丁5);
    XG:漲買入 OR SS OR DD;

    Q4:通達信公式怎么合并

    兩個公式合并是沒有問題,但是,第二個公式最后的DD函數沒有輸出,好像沒什么意義(故加了一句XG:SS OR DD),也許您另有用途,故合并后的源碼如下:

    (如果對您有幫助,請記得采納答案,謝謝)

    DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
    DEA:=EMA(DIFF,5);
    A1:=DIFF>DEA;
    RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
    K:=SMA(RSV1,3,1);D:=SMA(K,3,1);A2:=K>D;LC:=REF(CLOSE,1);
    RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
    RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
    A3:=RSI1>RSI2;RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
    LWR1:=SMA(RSV,3,1);LWR2:=SMA(LWR1,3,1);A4:=LWR1>LWR2;
    BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
    A5:=CLOSE>BBI;MTM:=CLOSE-REF(CLOSE,1);
    MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
    MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
    A6:=MMS>MMM;
    漲買入:IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0);
    丁丁1:=EMA(C,3),COLORWHITE;
    丁丁2:=EMA(C,5),COLORYELLOW;
    丁丁3:=EMA(C,7),COLORBROWN;
    丁丁4:=EMA(C,12),COLORLIGREEN;
    丁丁5:=EMA(C,20),COLORRED;
    SS:=CROSS(丁丁1,丁丁2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁1,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁2,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁1,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁1,丁丁4);
    DRAWICON(SS,L-0.04,5);
    DD:=CROSS(丁丁2,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁2,丁丁5) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁3,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
    OR CROSS(丁丁2,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁1,丁丁5);
    XG:SS OR DD;

    Q5:通達信軟件的指標模板如何導出?

    通達信目錄下T0002pad目錄中,隨你拷貝或復制或者
    數據下載Vipdoc
    自選股票T0002\blocknew\ZXG.blk
    自編公式T0002\PriGS.DAT
    自編模板T0002\PriPack.DAT
    系統設置(常用指標)T0002\user.配置設置
    看看能不能幫到你

    Q6:通達信怎么保存公式

    自己創建的公式可以保存,如果僅是修改原有公式,會在重新登陸后還原。

    上一篇:上一篇:股評的張磊
    下一篇:下一篇:港股交掛牌融資經理歐陽
    • 評論列表

    發表評論:

    5544444